Рекомендованные сообщения



Не найдено.

7 posts in this topic

Когда сдал тест, то выходишь с интерьера и перед тобой маркер, становишься на маркер и пишет вы достигли места назначения, потом когда идешь к машинам и садишься в нее больше ничего не происходит, помогите пожалуйста.

case D_JOB+43:
	    {
	        if(!response) return 1;
			if(GetMoney(playerid) < 60000) return SendClientMessage(playerid, COLOR_GREY, ""cER"Недостаточно средств!");
			SendClientMessage(playerid, COLOR_BLUE, ""cPS"Поздравляем, Вы сдали тест");
			SendClientMessage(playerid, COLOR_BLUE, ""cPS"Выходите во двор и садитесь в свободный транспорт");
			SetPVarInt(playerid, "DrivingTest", 1);
			TransferMoney(playerid, -1, 60000);
			pPressed[playerid] = 0;
			UseGPS[playerid] = true;
			for(new i; i < 3; i++) TextDrawShowForPlayer(playerid, GPSEnabled[i]);
    		DisablePlayerRaceCheckpoint(playerid);
			SetPlayerRaceCheckpoint(playerid,1,2179.4644, -2197.2510, 22.0133,0.0,0.0,0.0,5.0);
			return 1;
for(new v = 1; v <= TOTALVEH; v++)
				{
					if(vehicleid == VehInfo[v][vVehicle])
					{
						if(VehInfo[v][vFraction] == TEAM_AUTOSCHOOL && GetPVarInt(playerid, "DrivingTest") > 0
						&& VehInfo[v][vVehicle] == vehicleid && (v >= 14  && v <= 17))
						{
						    if(UseGPS[playerid])
							{
						    	DisablePlayerRaceCheckpoint(playerid);
						    	UseGPS[playerid] = false;
						    	for(new i; i < 3; i++) TextDrawHideForPlayer(playerid, GPSEnabled[i]);
							}
							SendClientMessage(playerid, COLOR_BLUE, ""cPS"Следуйте по чекпоинтам, соблюдая правила дорожного движения");
       						ShowPlayerDialog(playerid, D_NULL, 0, " ", "\n\n{ffffff}Ваша задача следовать по чекпоинтам. Вперед\n\n", "Закрыть", "");
							new i = pPressed[playerid];
							SetPlayerRaceCheckpoint(playerid,0,DrivingTest[i][0],DrivingTest[i][1],DrivingTest[i][2],DrivingTest[i][3],DrivingTest[i][4],DrivingTest[i][5],5.0);
						}

 

Share this post


Link to post
Share on other sites

Как я понял, мод у тебя just. Ну смотри, ставлю ставку что садишься ты не в тот транспорт, создай через команду /add машину автошколе. Пример: 466, 1, 1, 6, 0 (466 - ид машины, 1, 1 - цвет, 6 – ид фракции, 0 – ранг, который будет иметь доступ к автомобилю, у нас это доступ для всех, то есть 0). Далее, припаркуй её через команду /vpc и всё должно работать.

 

Если маркер действительно не появился, то тебе их придётся расставить, возможно, что маркер очень далеко стоит, поэтому ты его не видишь.

 

А если сервер с бонусом, то можно сделать ещё проще, в стоке CreateAccount при регистрации выдавай права на автомобиль, и всё :)

Edited by w1zardz

Share this post


Link to post
Share on other sites

@w1zardz Да права при регистрации уже сделал, но машины созданы правильно, и в этой строке вписал правильны ид авто, но когда выхожу с автошколы есть маркер какой-то у входа, когда становлюсь на него пишет вы достигли места назначения, а вот когда сажусь в авто ничего не происходит

&& VehInfo[v][vVehicle] == vehicleid && (v >= 14  && v <= 17))

 

@w1zardz По поводу того что ты говоришь маркер далеко, в теории там должен вылезти диалог который говорит что дальше делать

Share this post


Link to post
Share on other sites

Укажи ID транспорта, который в БД был создан для фракции автошкола.

Share this post


Link to post
Share on other sites

@w1zardz там всё правильно

 

Share this post


Link to post
Share on other sites
30 минут назад, archiboy6 сказал:

@w1zardz там всё правильно

 

Просто ты наверное скачал ту сборку которая с багами, попробуй скачать сборку с названием "Cлив Just RP(не реклама) БАГОФИКС".

Share this post


Link to post
Share on other sites

@archiboy6 второй код где находится? 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • Radmiz
      By Radmiz
      Добрый вечер, у меня образовалась проблема! Я уже как 1-2 месяца назад скачал этот мод, там было всё прекрасно но вдруг появилась проблема с маппингом типо он не удаляеться. Тоесть объекты были удалены а теперь как будто этого и не было вот скрины > https://yapx.ru/v/Kwrv1