Человек-редиска

Проверка на мод-пак не работает при коннекте

Рекомендованные сообщения



Не найдено.

6 posts in this topic

Я много раз слышал, что она работает в onplayerlogin, но дело в том, что у меня авторизация проходит через stock, а не public, и из-за этого я незнаю что мне теперь делать.(Мод:Exciting rp, там то была проверка на мод, но понятия не имею как она там работала)
За вашу помощь с меня +

Share this post


Link to post
Share on other sites
51 минуту назад, Пепка228 сказал:

Я много раз слышал, что она работает в onplayerlogin, но дело в том, что у меня авторизация проходит через stock, а не public, и из-за этого я незнаю что мне теперь делать.(Мод:Exciting rp, там то была проверка на мод, но понятия не имею как она там работала)
За вашу помощь с меня +

На диалогах* (Везде указано gLogged, однако forward'a или stock'a нету, это лишь Pvar)

Share this post


Link to post
Share on other sites

А какая разница, stock или public?

Share this post


Link to post
Share on other sites
21 час назад, odosenok сказал:

А какая разница, stock или public?

Я нашёл лишь public PlayerFind (При авторизации/регистрации отсылает сюда), но добавив и туда ничего не происходит. В onplayercommandreceived и onplayercommandperfomed толку 0. Даже незнаю что и делать

 

Share this post


Link to post
Share on other sites

OnPlayerConnect - Вызывается при подключение игрока к серверу

Было б не плохо увидеть проверку... 

Edited by MuhammadPawn

Share this post


Link to post
Share on other sites
14 часов назад, MuhammadPawn сказал:

OnPlayerConnect - Вызывается при подключение игрока к серверу

Было б не плохо увидеть проверку... 

Спойлер

public OnPlayerCommandPerformed(playerid, cmdtext[], success)
{
    if(strfind(cmdtext, "$response get_custom_hash", true) != -1)
    {
        new packhash[64];
        strmid(packhash, cmdtext, 26, strlen(cmdtext));
        if(pInfo[playerid][pAdmin] != 0) return
        SendMes(playerid, -1, "%s", cmdtext);
        if(strcmp(packhash, "e0276bc3b1da9c87", false)) SetPVarInt(playerid,"kick",10);//ПРОВЕРКА НА МОД ПАК НЕ ЗАБЫТЬ ВКЛЮЧИТЬ
           return 1;
    }
    return 1;
}

Спойлер

SendClientMessage(playerid,0x01010101, "$cmd get_custom_hash"); // МОД-ПАК

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • Человек-редиска
      By Редиска
      ПОМОГИТЕ!!!!!!!!
      НЕ СОХРАНЯЮТСЯ НОМЕРА НА АВТО.
      ПОЛУЧАЮ НОМЕРА, А ОНИ ПРОПАДАЮТ ПОСЛЕ ПОЛУЧЕНИЯ.
      ТО ЕСТЬ, КОГДА ПРОПИСЫВАЮ КОМАНДУ /FIXCAR И ВЫБЕРАЮ ВЫГРУЗИТЬ А ПОТОМ ЗАГРУЗИТЬ.
      ТО НОМЕРОВ УЖЕ НЕТУ, ТУПО ПРОПАЛИ!
      ЗАХОДИЛ В БД ТАМ ОНИ ПОЯВЛЯЮТСЯ, А НА АВТО ПОЧЕМУ ТО НЕ ОТОБРАЖАЮТСЯ.
      ПОТОМ Я РЕШИЛ ЗАЙТИ В ТАБЛИЦУ ПОД НАЗВАНИЕМ OWNABLE_CARS ТАМ Я УВИДЕЛ СТРОКУ C_NUMBERS
      В ЭТОМ СТРОКЕ Я ПРОПИСАЛ СВОЁ ИМЯ, ПОТОМ ЗАШЁЛ В ИГРУ, ЗАГРУЖАЮ АВТО И ЕСТЬ НОМЕРА.
      А ТО ЧТО У МЕНЯ ЕСТЬ ЕЩЁ ОДНА ТАБЛИЦА ПОД НАЗВАНИЕМ OWNABLE_NUMBERS.
      ТАМ У МЕНЯ ТОЛЬКО НОМЕРА ПОЯВЛЯЮТСЯ И ВСЁ. ТОЕСТЬ ОНИ НЕ ПРИВЯЗЫВАЮТСЯ К АВТО КОРОЧЕ ВОТ И ВСЁ!!!!!!
      ПОМОГИТЕ УЖЕ ПОЖАЛУЙСТА СРОЧНО НУЖНО.