Рекомендованные сообщения



Не найдено.

4 posts in this topic

Здравствуйте! помогите пожалуйста, незнаю из за чего вылезают ошибки в Mysql.Log, Вот сами ошибки:

Спойлер

[16:47:21] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('0')
[16:47:21] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('0')
[16:47:21] [ERROR] cache_get_field_content_int - invalid datatype
[16:47:21] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('0')
[16:47:21] [ERROR] cache_get_field_content_int - invalid datatype
[16:47:21] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('0')
[16:47:21] [ERROR] cache_get_field_content_int - invalid datatype
[16:47:21] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('0')
[16:47:21] [ERROR] cache_get_field_content_int - invalid datatype
[16:47:21] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('0')
[16:47:21] [ERROR] cache_get_field_content_int - invalid datatype
[16:47:21] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('0')
[16:47:21] [ERROR] cache_get_field_content_int - invalid datatype
[16:47:21] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('0')
[16:47:21] [ERROR] cache_get_field_content_int - invalid datatype
[16:47:21] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('0')
[16:47:21] [ERROR] cache_get_field_content_int - invalid datatype
[16:47:21] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('0')
[16:47:21] [ERROR] cache_get_field_content_int - invalid datatype
[16:47:21] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('0')
[16:47:21] [ERROR] cache_get_field_content_int - invalid datatype
[16:47:21] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('0')
[16:47:21] [ERROR] cache_get_field_content_int - invalid datatype
[16:47:21] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('0')
[16:47:21] [ERROR] cache_get_field_content_int - invalid datatype
[16:47:21] [ERROR] CMySQLResult::GetRowDataByName() - invalid row index ('0')
[16:47:21] [ERROR] cache_get_field_content_int - invalid datatype


 

Edited by Andy

Share this post


Link to post
Share on other sites

В OnGameModeInit добавить (если строка mysql_log уже есть, заменить): 

mysql_log(LOG_ALL);

После очистите файл mysql_log.txt, попробуйте вызвать эту ошибку заново и скиньте снова mysql_log.txt. 
 

Share this post


Link to post
Share on other sites

После того как вставил это в OnGameModeInit в Mysq.Log кроме этого ничего не появляется..

 


[17:15:20] [DEBUG] mysql_connect - host: "185.180.231.236", user: "gs809", database: "gs809", password: "****", port: 3306, autoreconnect: true, pool_size: 2
[17:15:20] [DEBUG] CMySQLHandle::Create - creating new connection..
[17:15:20] [DEBUG] CMySQLHandle::CMySQLHandle - constructor called
[17:15:20] [DEBUG] CMySQLHandle::Create - connection created (id: 1)
[17:15:20] [DEBUG] CMySQLConnection::Connect - establishing connection to database...
[17:15:20] [DEBUG] CMySQLConnection::Connect - connection was successful
[17:15:20] [DEBUG] CMySQLConnection::Connect - auto-reconnect has been enabled
[17:15:20] [DEBUG] mysql_tquery - connection: 1, query: "SET CHARACTER SET cp1251", callback: "(null)", format: "(null)"
 

Share this post


Link to post
Share on other sites

@Andy попробуйте зайти и выйти с сервера. Проблема скорее всего в сохранении. 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • nocare.
      By nocare.
      Фризит(замораживает) при телепортах, переходах через пикапы, и так далее. Помогите, не могу понять в чем проблемма