Question

После рестарта постоянно у игроков меняются дома местами, то есть, игрок купил дом, после рестарта его дом перенесся в другое рандомное место (где создан дом, но не куплен) Какой код скинуть?

Share this post


Link to post

3 answers to this question

  • 0

@archiboy6, а как это "где создан дом, но не куплен"? Дома что ли создаются в одном месте, а покупаются в другом?

Share this post


Link to post
  • 0

@odosenok Нет, дома созданы по всей карте, но купленные дома после рестарта меняются местами с не купленными рандомно, то есть, тот что до рестарта  был куплен, стал свободным, а что был свободный(рандомный) становится купленным

Edited by archiboy6

Share this post


Link to post
  • 0

@archiboy6, возможно, в коде сохранения дома как условие указывается неверный ID дома (например, имеющий сдвиг на единицу вперед или назад). Попробуй создать дом, найти именно его в базе данных. Затем купи его и посмотри, для кого дома в базе данных ты стал владельцем. А сюда напиши ID из базы данных созданного дома и ID из базы данных купленного дома.

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • DenriHanzo
      By DenriHanzo
      Ошибка в скрипте 
      C:\Users\HP\Desktop\Arizona Role Play\gamemodes\arizonarp.pwn(7576) : error 017: undefined symbol "MAX_INV_TYPE" C:\Users\HP\Desktop\Arizona Role Play\gamemodes\arizonarp.pwn(7576) : error 017: undefined symbol "InvType" C:\Users\HP\Desktop\Arizona Role Play\gamemodes\arizonarp.pwn(7576) : error 017: undefined symbol "i" C:\Users\HP\Desktop\Arizona Role Play\gamemodes\arizonarp.pwn(7576) : fatal error 107: too many error messages on one line Вот и сам код:
       
       
      7576:
      for(new i; i < MAX_INV_TYPE; i ++)CallRemoteFunction("InvTypeAdd", "dddbssffffffffffd",InvType[invMax],  
    • Daniil_Boiko
      By Daniil_Boiko
      При кипляции выскачила ошибка 
      : error 001: expected token: ";", but found "-identifier-"