Рекомендованные сообщения



9 posts in this topic

Как на данную команду наложить свой звук(url) ?

Спойлер

CMD:engine(playerid)
{
    if(GetPlayerState(playerid) != PLAYER_STATE_DRIVER) return 0;
    new vehicleid = GetPlayerVehicleID(playerid);
    if(!IsAPlane(vehicleid)) return 0;
    GetVehicleParamsEx(vehicleid,engine,lights,alarm,doors,bonnet,boot,objective);
    SetVehicleParamsEx(vehicleid,(Engine[vehicleid])?(false):(true),lights,alarm,doors,bonnet,boot,objective);
    Engine[vehicleid] = (Engine[vehicleid])?(false):(true);
    return 1;
}

 

Share this post


Link to post
Share on other sites

@Timur_Top 

PlayAudioStreamForPlayer(playerid, "Ссылка на аудио");

Или же можете воспользоваться стандартными звуками:

PlayerPlaySound(playerid, id_sound); 

 

Share this post


Link to post
Share on other sites

@Timur_Top да, после проверки можно добавить уже. 

Share this post


Link to post
Share on other sites

@DEST У меня команда сама не работает почему то..

 

Share this post


Link to post
Share on other sites

@Timur_Top по коду она будет работать только на самолетах. 

Замените ее следующей командой:
 

CMD:engine(playerid)
{
    if(GetPlayerState(playerid) != PLAYER_STATE_DRIVER) return 0;
    new vehicleid = GetPlayerVehicleID(playerid);
    if(IsAPlane(vehicleid)) return 0;
    GetVehicleParamsEx(vehicleid,engine,lights,alarm,doors,bonnet,boot,objective);
    SetVehicleParamsEx(vehicleid,(Engine[vehicleid])?(false):(true),lights,alarm,doors,bonnet,boot,objective);
    Engine[vehicleid] = (Engine[vehicleid])?(false):(true);
    //звук
    return 1;
}

 

Share this post


Link to post
Share on other sites

@Timur_Top да

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • Джеймс
      By Джеймс
      Здравствуйте Ув.Участиники PAWNO-RUS,
      Столкнулся с проблемой - *Транспорт сломанный при загрузке на сервер* То есть загружаешь Т.С после покупки с 50% состоянии
      С исправлением затрудняюсь, может вы можете как то помочь.
      Заранее спасибо!